missing subkey

Neil Williams linux at codehelp.co.uk
Mon Jun 28 00:58:49 CEST 2004

This hasn't appeared after 24hrs, re-posting.

Was anyone else able to verify Stoyan's message on the list (Re: Detection of 
sign-only vs. sign-and-encrypt keys) Yesterday 1:12:04 and again today?

I use Debian unstable, GnuPG 1.2.4 and --auto-key-retrieve and 
--include-subkeys with keyserver.kjsl.com but the subkey is not found, even 
though the main key is imported seemingly successfully. 

The subkey shows up on the search results page using a www interface, but it 
is not imported.

Here's my output:

On Saturday 26 June 2004 7:59, you wrote:
> I have published this key already @ random.sks.keyserver.penguin.de
 gives the main key as 0xB8D71FB6 - which I already have in the keyring:

gpg: Signature made Sat Jun 26 07:59:42 2004 BST using DSA key ID 1E3D95C3
gpg: key B8D71FB6: "Stoyan Dimitrov " not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
gpg: Can't check signature: public key not found

Your key only shows up with one subkey, 5831A000

neil at garfield:~$ gpg --delete-key B8D71FB6
gpg (GnuPG) 1.2.4; Copyright (C) 2003 Free Software Foundation, Inc.
This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it
under certain conditions. See the file COPYING for details.

pub  1024D/B8D71FB6 2004-06-15   Stoyan Dimitrov

Delete this key from the keyring? yes

neil at garfield:~$ gpg --import

(pasted the key block as on this page:)

gpg: key B8D71FB6: public key "Stoyan Dimitrov " imported
gpg: Total number processed: 1
gpg:               imported: 1
neil at garfield:~$ gpg --list-key  B8D71FB6
pub  1024D/B8D71FB6 2004-06-15 Stoyan Dimitrov
uid                            Stoyan Dimitrov
uid                            Stoyan Dimitrov (stoyanski) 
sub  2048g/5831A000 2004-06-15

No second subkey, despite it being shown on the search page.

I also tried my preferred keyserver and had the same result. The subkey shows 
in the results but is not imported.

I've sent this to the list as well because I can't see what has happened to 
the key and how the second subkey can be imported.


Neil Williams


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: signature
Url : /pipermail/attachments/20040627/b26cee1a/attachment-0001.bin

More information about the Gnupg-users mailing list