Failed to build gnupg-1.2.4 on Windows with Cygwin and gcc 3.3.1]

Alex Chen alex_chen at
Wed May 19 19:23:46 CEST 2004

I downloaded gnupg-1.2.4 and tried to build it on Windows under Cygwin.

I did that under the bash shell.  I first ran 'configure', which took 
quite some time to finish.
Then I ran 'make' from the top directory.  The compilation seemed to 
went smoothly until
it came to linking.  Then I got the following error messages:

gcc  -g -O2 -Wall   -o mpicalc.exe  mpicalc.o ../cipher/libcipher.a 
i.a ../util/libutil.a ../intl/libintl.a
../mpi/libmpi.a(mpi-add.o)(.text+0x258): In function `mpi_add':
/cygdrive/c/download/GnuPG/gnupg-1.2.4/mpi/mpi-inline.h:119: undefined 
to `_mpihelp_sub_n'
../mpi/libmpi.a(mpi-add.o)(.text+0x32a): In function `mpi_add':
/cygdrive/c/download/GnuPG/gnupg-1.2.4/mpi/mpi-add.c:143: undefined 
reference to
pi/mpi-add.c:136: undefined reference to `_mpihelp_sub_n'

The list when on and on.  I suspect somehow the compiler was adding the 
leading '_' in referencing
the functions.  But I do not know how to change the configuration.

Has anyone encountered similar problem?
Any help is appreciated.

More information about the Gnupg-users mailing list