Failed to build gnupg-1.2.4 on Windows with Cygwin and gcc 3.3.1]

Alex Chen alex_chen at
Wed May 19 20:12:19 CEST 2004

It turns out that I have to turn off the assembly option, i.e. configure 

Alex Chen wrote:

> I downloaded gnupg-1.2.4 and tried to build it on Windows under Cygwin.
> I did that under the bash shell.  I first ran 'configure', which took 
> quite some time to finish.
> Then I ran 'make' from the top directory.  The compilation seemed to 
> went smoothly until
> it came to linking.  Then I got the following error messages:
> gcc  -g -O2 -Wall   -o mpicalc.exe  mpicalc.o ../cipher/libcipher.a 
> ../mpi/libmp
> i.a ../util/libutil.a ../intl/libintl.a
> ../mpi/libmpi.a(mpi-add.o)(.text+0x258): In function `mpi_add':
> /cygdrive/c/download/GnuPG/gnupg-1.2.4/mpi/mpi-inline.h:119: undefined 
> reference
> to `_mpihelp_sub_n'
> ../mpi/libmpi.a(mpi-add.o)(.text+0x32a): In function `mpi_add':
> /cygdrive/c/download/GnuPG/gnupg-1.2.4/mpi/mpi-add.c:143: undefined 
> reference to
> `_mpihelp_sub_n'
> ../mpi/libmpi.a(mpi-add.o)(.text+0x37a):/cygdrive/c/download/GnuPG/gnupg-1.2.4/m 
> pi/mpi-add.c:136: undefined reference to `_mpihelp_sub_n'
> The list when on and on.  I suspect somehow the compiler was adding 
> the leading '_' in referencing
> the functions.  But I do not know how to change the configuration.
> Has anyone encountered similar problem?
> Any help is appreciated.
> _______________________________________________
> Gnupg-users mailing list
> Gnupg-users at

More information about the Gnupg-users mailing list