Problem with gpgme 1.0.2

harry_b at harry_b at
Fri Apr 8 15:04:04 CEST 2005

Hi guys,

I was battling this problem for quite some hours until I finally found a 
(temporary solution).

  - System: Debian unstable
  - gcc 3.3.5
  - libgpgme 1.0.2

The problem occured as this:
  1. when statically linked, the test t-encrypt-sign worked fine
  2. when dynamically linked, the test failed when gpgme_data_seek()
     was called

I tried to debug this for quite a long time until - with all my desperation 
- I had a look at the GTK project gpa. In there I found, that they don't 
use the recommended function gpgme_data_seek() but instead 
gpgme_data_rewind() which is considered to be deprecated.

I replaced the call to gpgme_data_seek() with gpgme_data_rewind() and all 
works fine now - the test code t-encrypt-sign compiles and runs properly 
and my own code works quite nicely as well.

What's the matter here and how can this be fixed? I assume that its not a 
good idea to use deprecated function to get the code working. ;-)



1024D/40F14012 18F3 736A 4080 303C E61E  2E72 7E05 1F6E 40F1 4012

Version: 3.12
GIT/S dx s: a C++ ULS++++$ P+++ L+++$ !E W++ N+ o? K? !w !O !M
V PS+ PE Y? PGP+++ t+ 5-- X+ R+ !tv b++ DI++ D+ G e* h r++ y++
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : /pipermail/attachments/20050408/880acd63/attachment.pgp

More information about the Gnupg-users mailing list