gpg: [don't know]: invalid packet (ctb=2d)

Sebastian Hofer shofer at
Sat Dec 3 18:56:42 CET 2005

Dear Listers,

I am a plain user of gnupg and new to this list. SO I would like to greet you 

Now the problem: I found some discussions about the "invalid packet (ctb=2d)" 
thing but none of it helped me.

I have been running gpg with the same keys since 2003. I started to use them 
on SuSE 7 and Win2K. Then I moved to Debian without a problem. Now I had a 
disc crash recently and switched to ubuntu. When I try to import or use my 
old keys I get this:

gpg: [don't know]: invalid packet (ctb=2d)
gpg: keydb_get_keyblock failed: eof
gpg: [don't know]: invalid packet (ctb=2d)
gpg: /home/seb/.gnupg/pubring.gpg: copy to `/home/seb/.gnupg/pubring.gpg.tmp' 
failed: invalid packet
gpg: error writing keyring `/home/seb/.gnupg/pubring.gpg': invalid packet
gpg: [don't know]: invalid packet (ctb=2d)
gpg: keydb_search failed: invalid packet
gpg: key 09D50FE7: public key "[User ID not found]" imported
gpg: [don't know]: invalid packet (ctb=2d)
gpg: keydb_search failed: invalid packet
gpg: [don't know]: invalid packet (ctb=2d)
gpg: error reading `/home/seb/.gnupg/secring.gpg': invalid packet
gpg: import from `/home/seb/.gnupg/secring.gpg' failed: invalid packet
gpg: Total number processed: 0
gpg:               imported: 1
[GNUPG:] IMPORT_RES 0 0 1 0 0 0 0 0 0 0 0 0 0 0

The keys where transfered from my external HD (backup) with all the other 
stuff in my home directory. 
Some weeks ago I tried import a copy the keys I still had on a W2K machine at 
work. Same error.
Today I thought I will use the weekend to fix the problem. One of my guesses 
is that there are conflicts between my new ubuntu and the old stuff I got 
from my backup done on Debian Sarge?!? So I wanted to erase gpg completly and 
then reinstall it. But there are billions of dependencies ... What should I 

Thanks in advance and cheers,

More information about the Gnupg-users mailing list