Solved: gpg: [don't know]: invalid packet (ctb=2d)

Sebastian Hofer shofer at
Sat Dec 17 19:35:07 CET 2005

Dear Listers,

I solved my problem (see at the bottom). But first the SUM of the answers I 

No answers, nor reactions oder hints :(

The solution was:
I had to delete the .gnupg-directory in my home directory. It seems like I 
copied old settings from Debian to Ubuntu taht caused the troubles.


Am Samstag 03 Dezember 2005 18:56 schrieb Sebastian Hofer:
> Dear Listers,
> I am a plain user of gnupg and new to this list. SO I would like to greet
> you first.
> Now the problem: I found some discussions about the "invalid packet
> (ctb=2d)" thing but none of it helped me.
> I have been running gpg with the same keys since 2003. I started to use
> them on SuSE 7 and Win2K. Then I moved to Debian without a problem. Now I
> had a disc crash recently and switched to ubuntu. When I try to import or
> use my old keys I get this:
> ---snip----
> gpg: [don't know]: invalid packet (ctb=2d)
> gpg: keydb_get_keyblock failed: eof
> gpg: [don't know]: invalid packet (ctb=2d)
> gpg: /home/seb/.gnupg/pubring.gpg: copy to
> `/home/seb/.gnupg/pubring.gpg.tmp' failed: invalid packet
> gpg: error writing keyring `/home/seb/.gnupg/pubring.gpg': invalid packet
> gpg: [don't know]: invalid packet (ctb=2d)
> gpg: keydb_search failed: invalid packet
> gpg: key 09D50FE7: public key "[User ID not found]" imported
> gpg: [don't know]: invalid packet (ctb=2d)
> gpg: keydb_search failed: invalid packet
> [GNUPG:] IMPORTED 0C1E3D6C09D50FE7 [?]
> gpg: [don't know]: invalid packet (ctb=2d)
> gpg: error reading `/home/seb/.gnupg/secring.gpg': invalid packet
> gpg: import from `/home/seb/.gnupg/secring.gpg' failed: invalid packet
> gpg: Total number processed: 0
> gpg:               imported: 1
> [GNUPG:] IMPORT_RES 0 0 1 0 0 0 0 0 0 0 0 0 0 0
> ---snap----
> The keys where transfered from my external HD (backup) with all the other
> stuff in my home directory.
> Some weeks ago I tried import a copy the keys I still had on a W2K machine
> at work. Same error.
> Today I thought I will use the weekend to fix the problem. One of my
> guesses is that there are conflicts between my new ubuntu and the old stuff
> I got from my backup done on Debian Sarge?!? So I wanted to erase gpg
> completly and then reinstall it. But there are billions of dependencies ...
> What should I do?
> Thanks in advance and cheers,
> Seb
> _______________________________________________
> Gnupg-users mailing list
> Gnupg-users at

More information about the Gnupg-users mailing list