unable to execute program `gpgkeys_hkp': Permission denied

Stewart V. Wright swright at physics.adelaide.edu.au
Thu Feb 10 21:23:41 CET 2005

G'day David,

Sorry about the delay in replying, work got in the way of fun!

* David Shaw <dshaw at jabberwocky.com> [050209 21:43]:
> Try this spec file.  If it works for you, I'll put it in 1.4.1.  It
> works ok on a FC3 box here.

Sorry to say, but this still doesn't work on my FC2 box.  :-(

Two problems: 

 1) The location of the gpgkeys_* files is still wrong.
 2) The info "dir" file still doesn't get created.

CAVEAT: I modified the .spec file so that it tries to install the
1.4.0 release - I didn't try 1.4.1rc1 so the first problem might have
gone away...  I will have a go with 1.4.1rc1 when I get some more


1) File location problems.

This new spec file installs the gpgkeys_* in /usr/libexec/gnupg/ as
one would hope, but gpg looks for them in /usr/libexec/gnupg/gnupg/!

It looks like there is some doubling up of libexecdir in the spec file
and keyserver/Makefile.am...  libexecdir in keyserver/Makefile.am is
defined as @libexecdir@/@PACKAGE@ which would give the extra layer of
gnupg causing the problem.

I'll leave the fix as an exercise for the reader!  ;-)

2) info "dir" file.

I'm not entirely sure that it isn't user error, but I can build RPMs
from pretty much everything else without problems.  :-(

The error I still get from (rpmbuild -bb gnucash.spec) is the



make[2]: Nothing to be done for `install-data-am'.
make[2]: Leaving directory `/tmp/fedora/tmp/gnupg-1.4.0'
make[1]: Leaving directory `/tmp/fedora/tmp/gnupg-1.4.0'
+ /usr/lib/rpm/redhat/find-lang.sh /tmp/fedora/tmp/rpmbuild_gnupg-1.4.0 gnupg
+ rm /tmp/fedora/tmp/rpmbuild_gnupg-1.4.0/usr/share/gnupg/FAQ
+ rm /tmp/fedora/tmp/rpmbuild_gnupg-1.4.0/usr/share/gnupg/faq.html
+ rm /tmp/fedora/tmp/rpmbuild_gnupg-1.4.0/usr/share/info/dir
rm: cannot remove `/tmp/fedora/tmp/rpmbuild_gnupg-1.4.0/usr/share/info/dir': No such file or directory
error: Bad exit status from /tmp/fedora/tmp/rpm-tmp.2023 (%install)
RPM build errors:
    Bad exit status from /tmp/fedora/tmp/rpm-tmp.2023 (%install)


When I comment out the "rm ..../info/dir" line from the spec file the
creation of the .rpm goes ahead successfully.

As I said, I'm not sure if this is the fault of something I'm doing,
or FC2, but GnuPG is the only code that seems to have this problem for


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 274 bytes
Desc: Digital signature
Url : /pipermail/attachments/20050210/1a317229/attachment.pgp

More information about the Gnupg-users mailing list