gpg --keyserver

lord grinny grinny3004 at
Wed Jan 26 19:03:53 CET 2005

Thanks very much for your response,
I tried  your suggestion but with no effect. I don't
think it's a problem in my 
network setup, but that the problem lies with (my
installation of) gpg.

Henry Hertz Hobbit wrote:
> <SNIP>
> You wrote:
>>I tried this, but my DNS is definitly set up okee.
>>C:\Documents and
>>*** Can't find server name for address
>>Non-existent domain
>>*** Default servers are not available
>>Server:  UnKnown
>>Non-authoritative answer:
>> is my gateway (A windows 98 box serving
>>a router)
> OH!  Did you see my comment about what you have to
do with
> a router?  I advise you to copy the files over to
> Windows 98 box that is doing the service as a router
> retrieve the key.  If you have an auto install, just
> it, and then copy the following files from your
> machine into the same folder on the new machine:
>         REM there are SEVERAL pubring files
>         pubring.*
>         secring.gpg
>         trustdb.gpg

Gpg still gives the same result:

gpg: requesting key BB36BA75 from hkp server
Port:           80
Command:        GET
gpgkeys: HTTP URL is
?: Host not found: ec=10065
gpgkeys: HKP fetch error: No error
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

I've setup firefox too use the same proxy
configuration and I can reach the site

without any problem. Allthough nslookup complaint
about not knowing the host 
name of the router, it did give the correct result.
Ping also translates the 
hostname to a correct ip address, so I really don't
think this is a DNS problem.

The weirdest thing is that I get a different error
message when I use the ip 
address.... Since I know the rest of my applications
are setup correctly, so I 
know the network is okee, this leads me to believe
that either I'm _that_ stupid 
and fucked up my settings again (this has happened
before :-) ), or this is a 
bug in gpg.

gpg: requesting key BB36BA75 from hkp server
Command:        GET
gpgkeys: HTTP URL is
gpgkeys: HKP fetch error: No error
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

> BTW,  are you using actual gpg or WinPT?  I advise
> you use WinPT, but copy the executable files in the
> Program Files area to some place in your path, e.g.,
> into C:\Windows.  It offers hot key support and does
> lot more.  WinPT stores the above files in:
> C:\Documents and
> I have played around long enough with GPGOE that I
> NOT advise it.  It cannot sign email messages, and
> automation for encryption is only outward bound. 
> it comes in, you have to select all of the encrypted
> email, CTRL+C it, and then do a CTRL+ALT+D to
> the Clipboard, then open some sort of editor and
> CTRL+V (paste) it into the editor.  I advise moving
> Thunderbird.  It will encrypt INLINE (what GPGOE
> and MIME (the default for a lot of other email
> and most importantly, it will allow you do SIGN your
> messages.  That is the only part of gpg I need a

I allready use Thunderbird, I also have enigmail
installed, but since fetching 
keys didn't work, I went back to basic and tried to
retrieve a key from the 
console. Since that too failed I know the problem lies
with gpg.


- Grinny -

the source of my problems is in the source...

Do you Yahoo!? 
Yahoo! Mail - 250MB free storage. Do more. Manage less.

More information about the Gnupg-users mailing list