group options

Thu Mar 3 21:32:15 CET 2005

ok so in my conf file I have as below

> group HlthStream = keyid1 keyid2
> no-tty
> no-secmem-warning
> no-mdc-warning

then my command is :   gpg -e -t -a -d "my key" - - group HlthStream

Is there something else I am doin wrong?

Derek B. Smith
OhioHealth IT
UNIX / TSM / EDM Teams

             David Shaw                                                    
             <dshaw at jabberwock                                             
   >                                                     To 
             Sent by:                  gnupg-users at,              
             gnupg-users-bounc         gnupg-users-bounces at       
             es at                                               cc 
             03/03/2005 03:11          Re: group options                   

On Thu, Mar 03, 2005 at 01:43:38PM -0500, DBSMITH at wrote:
> > I use PGP to encrypt data for sending to various end users by
> > encrypting files using their public key they have provided.  To make
> > it possible for me to associate their key with a meaningful user_id
> > , I use the PGP --group-add option to create a group name containing
> > a meaninful user_id and then add their public key to the group.
> > Now, I can call --encrypt with the meaningful user_id, instad of
> > having to use the actual key id.  I'm looking for a similar "alias"
> > functionality in GPG but I can't find anything that works quite like
> > that.  The adduid command requires that I have the private key also
> > that goes with the public key I want to associate with a meaningful
> > user_id.
> >
> > Does anyone know of a solution that is part of the GPG
> > functionality?
> Yes, there is a --group command.  Stick in your gpg.conf file:
> group name_you_want_to_use = keyid1 keyid2 keyid3 keyid4
> David
> I tried this and the error I am getting is:
> gpg: no = sign found in group definition "HlthStream"
> my conf file is
> group HlthStream = keyid1 keyid2
> no-tty
> no-secmem-warning
> no-mdc-warning

I tried this using your conf file with both 1.4.0, and 1.2.8.  It
works fine for me.


Gnupg-users mailing list
Gnupg-users at

More information about the Gnupg-users mailing list