Libcurl (was Re: [Announce] GnuPG 1.4.1 released)

Carlo Luciano Bianco clbianco at
Sun Mar 20 16:18:35 CET 2005

Il /18 mar 2005/, *David Shaw* ha scritto:

> On Fri, Mar 18, 2005 at 06:09:11PM +0100, Carlo Luciano Bianco wrote:
>> > With libcurl as well?  Excellent.
> Understood.  I'm just pleased that it builds on MinGW at all.

Yes, it builds, but there is a small building problem I discovered in the
tests I did yesterday. The libcurl mingw version I used supports SSL but
has not a "config" script, so GnuPG's "configure" does not enable HTTPS
and FTPS. 

I fixed this by manually editing "config.h" after "configure" and before
"make", uncommenting the relevant definitions. 

Of course, this is not a GnuPG problem, but a mingw-libcurl one.

>> So, I cannot be sure that the gpgkeys_curl.exe I have compiled is
>> actually working right. I saw your post on gpg-devel about testing curl
>> code and I hope to have time to make some tests in the week-end...
> That would be great, thanks.

Thank you, David. Here is my report:

1) It seems that, when running a subprocess like a gpgkeys_*.exe, gpg.exe
does not pass it the environment variables. Most notably, it does not pass
the system %PATH%. Both gpg.exe and gpgkeys_*.exe depends on many dlls
(zlib, bzip2, libiconv, libintl, ecc.) which I keep in a separate folder
under "Common files" because they are used also by many other programs I
have (e.g. GIMP, gnuplot, ecc.). Of course, this folder is in the system
%PATH% and gpg.exe has no problems in finding the dlls he needs. But if I
try to retrieve a key from a keyserver (no matter what protocol), gpg.exe
tries to run the relevant gpgkeys_*.exe which returns an error saying that
some dlls are missing. If I copy the dlls in the gnupg folder everithing

2) gpgkeys_hkp.exe, gpgkeys_finger.exe and gpgkeys_ldap.exe seem to work
OK (provided the dlls are found), but gpgkeys_curl.exe does not run at
all. As soon as it is started by gpg.exe, it crashes (and DrWatson comes
out) even before trying to connect to the net (my firewall does not see
any connection). I tried many times, but always with the same result: a
crash. I have checked the temporary file gpg.exe uses to pass commands to
gpgkeys_curl.exe, but it seems OK to me... 

Are there any other test I can do to understand better the problem? Does
anybody else have these same problems? 

| Carlo Luciano Bianco | ICQ UIN: 109517158                              |
|______________________| Home page: <>    |
|GPG DSA/ElG 1024/4096:|_________________________________________________|
|KeyID:0x5324A0DA - Fingerprint:8B00C61034120506111B143DEDBF71B45324A0DA |

More information about the Gnupg-users mailing list