Libcurl (was Re: [Announce] GnuPG 1.4.1 released)

David Shaw dshaw at
Mon Mar 21 20:12:01 CET 2005

On Sun, Mar 20, 2005 at 04:18:35PM +0100, Carlo Luciano Bianco wrote:

> 1) It seems that, when running a subprocess like a gpgkeys_*.exe, gpg.exe
> does not pass it the environment variables. Most notably, it does not pass
> the system %PATH%. Both gpg.exe and gpgkeys_*.exe depends on many dlls
> (zlib, bzip2, libiconv, libintl, ecc.) which I keep in a separate folder
> under "Common files" because they are used also by many other programs I
> have (e.g. GIMP, gnuplot, ecc.). Of course, this folder is in the system
> %PATH% and gpg.exe has no problems in finding the dlls he needs. But if I
> try to retrieve a key from a keyserver (no matter what protocol), gpg.exe
> tries to run the relevant gpgkeys_*.exe which returns an error saying that
> some dlls are missing. If I copy the dlls in the gnupg folder everithing
> works. 

That's odd.  The only thing that jumps to mind is are you building
with the configure option "--disable-keyserver-path" or using the
GPG option "exec-path" ?

> 2) gpgkeys_hkp.exe, gpgkeys_finger.exe and gpgkeys_ldap.exe seem to work
> OK (provided the dlls are found), but gpgkeys_curl.exe does not run at
> all. As soon as it is started by gpg.exe, it crashes (and DrWatson comes
> out) even before trying to connect to the net (my firewall does not see
> any connection). I tried many times, but always with the same result: a
> crash. I have checked the temporary file gpg.exe uses to pass commands to
> gpgkeys_curl.exe, but it seems OK to me... 

Can you try running gpgkeys_curl.exe under gdb?  Just run it with the
temporary file you already got as the only command line argument.  It
would be very useful to see where it is failing.

I've gotten a number of successful reports of gpgkeys_curl on Unix-ish
machine, but has anyone had success with MinGW?


More information about the Gnupg-users mailing list