2 noob problems

Neil Williams linux at codehelp.co.uk
Tue May 3 10:00:25 CEST 2005

On Tuesday 03 May 2005 4:06 am, Matthew East wrote:
> First, when searching for keys on keyservers (i've tried the one
> supplied by default with gpg as well as pgp.mit.edu) using the "gpg
> --search-keys" command, it just sits there for ages without doing
> anything.

What command are you using? Search by keyid where possible or at least by 
something that's likely to be uncommon, like the email address. Don't 
underestimate how many keys are out there. 

> I have the agent enabled via evolution as well and that is 
> also just sitting there without finding the key. Can anyone help?

Can you connect to the keyserver at all? This could be a network problem or a 
firewall problem.

Try --recv-key with your keyid.

> The other thing is that, given that I am a beginner, I have self-signed
> my key a few times and then deleted the signature, when I was
> discovering how everything worked. Now I've discovered that my key
> appears like this (despite the fact that it seems fine if I check it
> locally):

Keyservers don't delete signatures so every time you self-sign, it remains on 
the keyserver. Deleting the signature once a key has been sent to a keyserver 
is pointless because refreshing the key will always import all the old 

> Is there anything I can do about this?

Don't send test keys to keyservers!

Revoke this key and start again with a new one. If you want to do more local 
testing, use a second key that you never send to a keyserver.

Keyservers exist for the benefit of others, not for your test purposes. The 
keys are there to help other people verify and sign your key. 


Neil Williams

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : /pipermail/attachments/20050503/5916a77e/attachment.pgp

More information about the Gnupg-users mailing list