trouble decrypting AES256 symmetric encrypted file

Ryan Malayter ryan at
Wed Sep 21 00:11:11 CEST 2005

On 9/20/05, Werner Koch <wk at> wrote:
> I have to commit that I did not try larger files on Windows for years
> (lack of disk space) so here might indeed be a problem with that.  A
> quick check however shows that GetFileSize is used correctly.

Werner, I can confirm that large file (> 4GB) support does not work on
Win32 without using file redirection, at least in version 1.4.1. Did
you make a change to enable 64-bit file sizes in a later version?

I would love to help fix this issue, but as I have not worked with C
much since 1996, I can probably really only contribute lots of
testing. Are there debug builds of GPG for win32 that might be useful
in this regard? Or will using "-vv" give the kind of information

Thank you for any help/ideas,
All problems can be solved by diplomacy, but violence and treachery
are equally effective, and more fun.

More information about the Gnupg-users mailing list