Compile of Gnupg 2.0.1 failed - no libintl

Peter Stoddard peter at
Thu Dec 7 01:46:34 CET 2006

On Dec 6, 2006, at 10:33 AM, Doug Barton wrote:

> Peter Stoddard wrote:
>> Hi folks
>> I tried compiling Gnupg 2.0.1 on a 733 MHz PowerPC G4 running Mac OSX
>> 10.4.8 and the make failed with the following error:
>> In file included from sysutils.c:41:
>> i18n.h:27:23: error: libintl.h: No such file or directory
>> sysutils.c: In function 'disable_core_dumps':
>> sysutils.c:88: warning: implicit declaration of function 'gettext'
>> sysutils.c:88: warning: incompatible implicit declaration of built-in
>> function 'gettext'
>> make[2]: *** [libcommon_a-sysutils.o] Error 1
>> make[1]: *** [all-recursive] Error 1
>> make: *** [all] Error 2
>> I looked libintl up and it involves native language support.  Is this
>> really necessary to ild Gnupg 2.x?  If so, is there source code
>> somewhere I can download?
> Try adding --disable-nls to your configure command. Also try doing
> './configure --help | more' to see if there is anything else there
> that is relevant, but only change things if you're pretty sure you
> know what's going to happen if you do. :)

Thanks for the suggestion Doug.  I tried configure --disable-nls, and  
I got further in the make but it eventually failed with the following  

/usr/bin/ld: Undefined symbols:
collect2: ld returned 1 exit status
make[2]: *** [kbxutil] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

I don't know what other configuration options to try, and I don't  
understand what *any* of them do, so I'm going to bag gnupg 2.0.1 and  
wait until I can find out what is going on, or maybe wait for a  
macosx binary.  I'm running 1.4.5 and its working fine for me.


Peter Stoddard  --  GPG Key 4A1F5DA0

Peter Stoddard  --  GPG Key 4A1F5DA0

More information about the Gnupg-users mailing list