Ohhhh jeeee: ... this is a bug (getkey.c:2079:merge_selfsigs)

Phil Pennock gnupg-users at spodhuis.demon.nl
Tue Feb 28 11:13:32 CET 2006

On 2006-02-27 at 23:39 -0500, David Shaw wrote:
> This is a heavily patched GnuPG release.  Did you try this on the
> official version?

I hadn't, since the official version has the mpicoder bug which causes
it to abort whilst processing some keys on my keyring; Gentoo pulls in
your patch, after I noted this and pointed to it;

Taking the official code and applying that patch, things worked;
but I then used the Gentoo gpg and things still worked.  So I'm now
confused.  I don't see what's different between the set-up yesterday and
today, except that baseline code has run over the keyring; I ran "gpg
--update-trustdb" with the Gentoo version and the problem is still

Okay, thanks.
I am keeping international relations on a peaceable footing.
You are biding your time before acting.
He is coddling tyrants.
 -- Roger BW on topic of verb conjugation

More information about the Gnupg-users mailing list