Ohhhh jeeee: ... this is a bug (getkey.c:2079:merge_selfsigs)

sbt at megacceso.com sbt at megacceso.com
Tue Feb 28 13:07:00 CET 2006

A Dimarts 28 Febrer 2006 11:13, Phil Pennock va escriure:
> On 2006-02-27 at 23:39 -0500, David Shaw wrote:
> > This is a heavily patched GnuPG release.  Did you try this on the
> > official version?
> I hadn't, since the official version has the mpicoder bug which causes
> it to abort whilst processing some keys on my keyring; Gentoo pulls in
> your patch, after I noted this and pointed to it;
>  <URL:http://marc.theaimsgroup.com/?l=gnupg-devel&m=112554412404623&w=2>
> <URL:http://www.gentoo.org/cgi-bin/viewcvs.cgi/app-crypt/gnupg/files/gnupg-

Ok, now it works, but can you send me any information that could be 
interesting? For example how you create the 0xC9541FB2, is it over finite 
fields o elliptics? Length, and this characteristics. Or what operations you 
did with patched gpg.

Over a patched gpg, could you have problems finite fields that you haven't on 
the official version. I could broke something (for sure accidentally) in the 
patch... Maybe the patch hurt the key ring.


> Taking the official code and applying that patch, things worked;
> but I then used the Gentoo gpg and things still worked.  So I'm now
> confused.  I don't see what's different between the set-up yesterday and
> today, except that baseline code has run over the keyring; I ran "gpg
> --update-trustdb" with the Gentoo version and the problem is still
> absent.
> Okay, thanks.

More information about the Gnupg-users mailing list