Problems Deleting Key and Adding Key to Keyring

Graham gct3 at
Mon Jan 30 09:22:33 CET 2006

I have Gpg 1.4.2 installed by default on my Mepis system.  When I tried 
to delete a key from my keyring both from the command line and through 
Kgpg I got this error:

gpg --delete-keys 0xCB1AA7B0

pub  1024D/CB1AA7B0 2003-11-18 Robert Blayzor (INOC) <rblayzor at>

Delete this key from the keyring? (y/N) y
gpg: /home/graham/.gnupg/pubring.gpg: copy to 
`/home/graham/.gnupg/pubring.gpg.tmp' failed: file read error
gpg: deleting keyblock failed: file read error
gpg: 0xCB1AA7B0: delete key failed: file read error

When I tried to import a key I got a similar file read error.

I tried renaming my .gnupg file as .gnupg_old, rerunning gpg --help so a 
new .gnupg file would be set up and copying my keyrings, gpg.conf file, 
and file.  Still no luck.

I've checked permissions and they seem OK with all access except by 
owner being forbidden.  I've tried adding 
a .gnupg/pubring/pubring.gpg.temp folder and file without success.

Anybody know what I should do to get this to work?



More information about the Gnupg-users mailing list