Problems Deleting Key and Adding Key to Keyring

Graham gct3 at
Mon Jan 30 17:48:44 CET 2006

On Monday 30 Jan 2006 08:22, Graham wrote:

> I have Gpg 1.4.2 installed by default on my Mepis system.  When I
> tried to delete a key from my keyring both from the command line and
> through Kgpg I got this error:
> gpg --delete-keys 0xCB1AA7B0
> pub  1024D/CB1AA7B0 2003-11-18 Robert Blayzor (INOC)
> <rblayzor at>
> Delete this key from the keyring? (y/N) y
> gpg: /home/graham/.gnupg/pubring.gpg: copy to
> `/home/graham/.gnupg/pubring.gpg.tmp' failed: file read error
> gpg: deleting keyblock failed: file read error
> gpg: 0xCB1AA7B0: delete key failed: file read error

I don't know why it did it, but solved the problem by naming  
pubring.gpg and secring.gpg with a suffix "old" (eg pubring.gpg.old), 
then doing an import on each file.  It asked me for my passphrase on 
each of my (old) keypairs but imported them fine.  I can now import and 
export keys to my hearts content!

As I said, I don't know what was wrong with the old keyrings, but its 
the simple things we tend to overlook....

HTH anyone with the same problem!


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 243 bytes
Desc: not available
Url : /pipermail/attachments/20060130/f4fa769f/attachment.pgp

More information about the Gnupg-users mailing list