Problem generating keys on FSFE card

Werner Dittmann Werner.Dittmann at
Tue Oct 17 20:07:15 CEST 2006


during generation of keys on the FSFE card I have some problems.
I'm using the how-to on the FSFE site to generate keys
(refer to the Using your Card with subkeys only (recommended) how-to).

The first time it worked as described. Because I wanted to change
some parameters (key validity dates) I tried it once again. During
this second time I got the following error message after some time
during key generation

gpg: Bitte warten, der Schlüssel wird erzeugt ...
gpg: pcsc_transmit failed: not transacted (0x80100016)
gpg: apdu_send_simple(0) failed: card I/O error
gpg: Schlüsselerzeugung fehlgeschlagen
gpg: key generation failed: Allgemeiner Fehler
Schlüsselerzeugung fehlgeschlagen: Allgemeiner Fehler

I'm using gpg (GnuPG) 1.4.2.

What I can report on top of this: during the second time
the order of the PIN entry was revered. When doing it the
first time gpg asked for the ADMIN PIN first, then for
the normal PIN. During second (and all subsequent tries)
it first asked the normal PIN, then the ADMIN PIN.

Because I was curious I tried to generated some keys using
the --card-edit / admin/ generate sequence. Same error message
are quite some while.

I disconnected the card reader to force a reset, did  reboot
to clear any "hanging" software - and always "pkill" the pgp-agent.
Nothing helped.

Any ideas? Need to "reset" the card?


More information about the Gnupg-users mailing list