Problem generating keys on FSFE card

Henry Bremridge henry.bremridge at
Wed Oct 18 07:05:29 CEST 2006

On Tue, Oct 17, 2006 at 08:07:15PM +0200, Werner Dittmann wrote:
> All,
> during generation of keys on the FSFE card I have some problems.
> I'm using the how-to on the FSFE site to generate keys
> (refer to the Using your Card with subkeys only (recommended) how-to).
> The first time it worked as described. Because I wanted to change
> some parameters (key validity dates) I tried it once again. During
> this second time I got the following error message after some time
> during key generation
> gpg: Bitte warten, der Schlüssel wird erzeugt ...
> gpg: pcsc_transmit failed: not transacted (0x80100016)
> gpg: apdu_send_simple(0) failed: card I/O error
> gpg: Schlüsselerzeugung fehlgeschlagen
> gpg: key generation failed: Allgemeiner Fehler
> Schlüsselerzeugung fehlgeschlagen: Allgemeiner Fehler
> I'm using gpg (GnuPG) 1.4.2.
> What I can report on top of this: during the second time
> the order of the PIN entry was revered. When doing it the
> first time gpg asked for the ADMIN PIN first, then for
> the normal PIN. During second (and all subsequent tries)
> it first asked the normal PIN, then the ADMIN PIN.
> Because I was curious I tried to generated some keys using
> the --card-edit / admin/ generate sequence. Same error message
> are quite some while.
> I disconnected the card reader to force a reset, did  reboot
> to clear any "hanging" software - and always "pkill" the pgp-agent.
> Nothing helped.
> Any ideas? Need to "reset" the card?

I have been having similar problems with gpg 1.4.5 on debian etch. With
-   When trying to generate keys for the card the problem (to me) seemed
    that I was using a 2048 bit key for encryption. I therefore deleted
    that sub-key and tried again. This worked in that my card got
    populated but now I cannot decrypt old emails
-   In restoring my secring, I still cannot decrypt old email, and
    cannot generate new sub-keys for the card. When I do I get similar
    message to the above

I am trying to find a way to remove all my existing key data from the
card so I can start again

Wed Oct 18 06:05:19 BST 2006

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : /pipermail/attachments/20061018/5c937a96/attachment.pgp

More information about the Gnupg-users mailing list