No Public Key Problem

Mitsuho Iizuka m-iizuka at
Tue Feb 6 10:14:41 CET 2007

Getting errors as follows, I can't sign by myself with gpgsm of
gnupg2.0.1 on Fedora Core 5 Linux. Could you give some hint ?

   gpgsm: can't sign using `<m-iizuka at>': No public key
   [GNUPG:] INV_RECP 1 <m-iizuka at>

command line are as follows.

   % ./gpgsm --detach-sign --include-certs 3 --status-fd 2 --local-user '<m-iizuka at>' --output smime.p7s mew5430s-F

I tried 2 other user specifying way, such as, m-iizuka at ... and
'<m-iizuka at>'. Those results gave almost same error. Only gave me valid sign.

My certification is as follows(~/.gnupg/keyring.kbx).

   % gpgsm -kv

   Serial number: XXXXXXX
   Issuer: /CN=NEC Group Certification Authority SMIME/OU=Class 2 CA - OnSite Individual Subscriber/OU=Terms of use at https:\x2f\\x2fRPA (c)99/OU=VeriSign Trust Network/O=NEC Corporation
   Subject: /CN=Mitsuho Iizuka (061221\x2frepository\x2fCPS Incorp. by Ref.,LIAB.LTD(c)96/OU=NEC Group Certification Authority SMIME/O=NEC Corporation/EMail=m-iizuka at

According to keydb.c at around 1035 line, I don't think there is
a method to specify myself with my e-mail address on the above my
certicication. How can I specify myself with gpgsm2.0.1 ?

Thanks in advance

// Mitsuho Iizuka

More information about the Gnupg-users mailing list