pinentry-mac never displays any UI

Richard Bronosky BrunosJunk at
Mon Oct 1 20:29:21 CEST 2007

I got a lead on how to use pinentry, and now have an error message to report:
echo GETPIN|/Applications/
OK Your orders please
2007-10-01 14:21:54.669 pinentry-mac[6312] *** _NSAutoreleaseNoPool():
Object 0x31eaf0 of class NSCFString autoreleased with no pool in place
- just leaking

Again, the icon appears in the dock and bounces once, but no UI.  I
hope that helps.

On 10/1/07, Richard Bronosky <BrunosJunk at> wrote:
> I've had no luck with the binary version that I downloaded based on
> Benjamin's various howtos and mailing list messages.  I have
> downloaded the source, and poked around it in Xcode.  I wanted to make
> sure that there was a GUI element to the  There is.
> I built it and tried placing both the build and debug versions in
> /Applications.  I've also downloaded and compiled pinentry-helper.c
> and placed it inside /Applications/
> and set ~/.gnupg/gpg-agent.conf to try it.
> Nothing works.  Same result in all cases.  The pinentry-mac icon
> bounces, but I have no UI to speak of.
> MacBookPro, Intel Core 2 Duo 2.2GHz, 2GB DDR2
> uname -a
> Darwin IT-F1-P-RBRONOSKY 8.10.1 Darwin Kernel Version 8.10.1: Wed May
> 23 16:33:00 PDT 2007; root:xnu-792.22.5~1/RELEASE_I386 i386 i386
> Please advise.
> --
> .!# RichardBronosky #!.

.!# RichardBronosky #!.

More information about the Gnupg-users mailing list