problem installing gnupg-2.0.9

Charly Avital shavital at
Mon Apr 14 05:56:58 CEST 2008

Hash: SHA256

Chris wrote the following on 4/13/08 8:41 PM:
> I can't seem to get the above installed. I get the below at the end of 
> configure, I've downloaded and attempted to install the below libraries but 
> to no avail it seems. Looking at the file dates in /usr/lib they all seem to 
> be the older version I've installed previously. Below is a link to the config 
> logs for gnupg-2.0.9 and the three libraries. I had no problems installing 
> gpg v1.4.9 except copying the binaries from /usr/local/bin to /usr/bin which 
> for some reason my box likes instead of the default install directory. 
> *** You need libgcrypt to build this program.
> **  This library is for example available at
> ***
> *** (at least version 1.2.2 using API 1 is required.)
> ***
> configure:
> ***
> *** You need libassuan with Pth support to build this program.
> *** This library is for example available at
> ***
> *** (at least version 1.0.4 (API 1) is required).
> ***
> configure:
> ***
> *** You need libksba to build this program.
> *** This library is for example available at
> ***
> *** (at least version 1.0.2 using API 1 is required).
> Any help would be greatly appreciated.
> Chris
Hi Chris,

The raw source of your e-mail indicates that you are using KMail.
If that's correct, I'll guess that you are running Linux.

I am a Macintosh user, but run Ubuntu 7.10 under virtual-ware Parallels 3.0.

I have compiled 2.0.9 under Ubuntu, upgrading from 2.0.7, and then 2.0.8.

GPG2 requires that certain libraries be installed, before gpg2 can
actually be compiled and installed.

The README file included in the expanded source code of 2.0.9 should
indicate exactly which libraries should be compiled and installed, and
in what order.

In addition to the libraries that you have indicated above, there is
also the issue of gettext. I believe that if you have already a gettext
version that is above 0.14, you are safe. Type in Terminal
gettext --version, and you'll know.

All the above is "the fruit" of my empirical knowledge. I have a very
basic, limited and unprofessional grasp of all these matters.

If you really want to install gpg2 in your Linux environment, just arm
yourself with patience, and be ready that in spite of your having
compiled and installed everything that is required, you  *might* still
get some error-warning that you still need some other library, or a more
recent version of one of the installed libraries.

Version: GnuPG v2.0.9 (Darwin)
Comment: GnuPG for Privacy
Comment: Using GnuPG with Mozilla -


More information about the Gnupg-users mailing list