passphrase works ONLY with enigmail

Bruno CAPELETO bruno.capeleto at
Fri Feb 8 03:38:39 CET 2008

I found the solution.

I had a carefull look at Enigmail Debug Console.

I found out some weird characters, that were only reproducible in a
console in X mode when default locale was ISO-8859-1. In addition, the
option --charset utf8 was used with gpg.

I fixed to this locale, restarted X, and use gpg --charset utf8 in a
console in X (didn't work outside X!) to change my passphrase.

Maybe this can help someone else...

Bruno CAPELETO a écrit :
> Dear all,
> I'm becoming crazy and begging for help.
> I generated a pair of key one month ago with gpg command line, I use GPG
> with Thunderbird/Enigmail.
> Everything fine until I tried gpg with gajim : my passphrase was
> systematically refused.
> As my passphrase contains accent (eg "à la ville, j'y vais de suite"), I
> thought I should try to change it to remove the accent (eg "a la ville,
> j'y vais de suite").
> Then I realized that my passphrase is also refused on the command line !
> I tried to change the locale (UTF-8, ISO-8859-1...) with no success.
> I also tried gpa with no success.
> As a conclusion, I can't change my passphrase, because it is accepted
> ONLY in Enigmail !
> Please help...
> Bruno
> _______________________________________________
> Gnupg-users mailing list
> Gnupg-users at

More information about the Gnupg-users mailing list