Decryption error

Paul Crittenden paul.crittenden at
Thu Jan 10 15:32:31 CET 2008

I ran ldd against the binary gpg and it found the file.

# ldd /usr/bin/gpg =>         /usr/local/lib/ =>        /usr/lib/ =>     /usr/lib/ =>      /usr/local/lib/ =>        /usr/lib/ =>    /usr/lib/ =>        /usr/lib/ =>   /usr/lib/ =>     /usr/lib/ =>         /usr/local/lib/ =>    /usr/lib/

Paul Crittenden
Computer Systems Manager
Simpson College
Phone: 515-961-1680
Email: paul.crittenden at

-----Original Message-----
From: gnupg-users-bounces at
[mailto:gnupg-users-bounces at] On Behalf Of David Shaw
Sent: Wednesday, January 09, 2008 9:26 PM
To: gnupg-users at
Subject: Re: Decryption error

On Wed, Jan 09, 2008 at 04:28:46PM -0600, Paul Crittenden wrote:
> I am using gpg for encryption with Amanda, a disk backup utility. It
> backups up just fine but when I try to restore I get the error:
> gpg: fatal: open failed: No such file or
> directory
> I have set environment variables both when I compiled gpg and when I
> the restore utility but I can't seem to get past this error.
> I have worked with the Amanda folks but still haven't figured this one
> out.

This isn't an Amanda issue or a GPG issue.  Rather, it's a regular old
Unix-ish shared library issue.  The error means that the gpg binary
was compiled on a system that could find, but is now
being run on a system that cannot.

Does the file exist at all on your machine?


Gnupg-users mailing list
Gnupg-users at


NOTE: This message was trained as non-spam.  If this is wrong,
please correct the training as soon as possible.

Teach CanIt if this mail (ID 17778430) is spam:
Not spam:
Forget vote:

More information about the Gnupg-users mailing list