Secret Key Not Available

David Shaw dshaw at
Fri Oct 3 21:24:41 CEST 2008

On Wed, Oct 01, 2008 at 04:45:51PM -0600, Tim Stebar wrote:
> Hello,
>     I created an EDI job (Trinary translation/schedule) that pulls down files and it decrypts just fine from the command line as well as if I spawn the EDI job from the command line.   However, if I schedule the job in Trinary (kicks off the job by itself) it will not decrypt the file.  It comes up with the following:
> $gpg -batch -passphrase gocatsgo -output out.txt -decrypt 810x12.pgp
> E:\ew\sv53\recv\tmp_recv>echo off
> Press any key to continue . . .
> gpg: encrypted with ELG-E key, ID 9B1D9DED
> gpg: decryption failed: secret key not available
> I have tried this with both a hard code passphrase (txt) as well as a passphrase file as well and still no luck?   Anyone ever run into this by chance?  I am wondering if it is something with the different environments or if it is how the Gnupg was installed maybe?

It's not a question of the passphrase; rather, the key isn't there.
If it works from the command line but not from the scheduled job, then
I'd check for differences in the environment.  Possibly you have two
different GPG home directories when run in your two different ways.
Check for different GNUPGHOME variables as well as different home
directories for your different run methods.


More information about the Gnupg-users mailing list