unable to send key to keyserver

Charly Avital shavital at mac.com
Sat Apr 4 12:10:33 CEST 2009

caleb wrote the following on 4/4/09 5:15 AM:
> Hi,
> I have been reading a book about openPGP and have installed GnuPG. I 
> have successfully created a keypair and have created a revocation 
> certificate. But when I try and send my key to a keyserver with the command:
> gpg --keyserver subkeys.pgp.net --send-keys myemail at mydomain.com.au
> i get an error:
> gpg: "myemail at mydomain.com.au" not a key ID: skipping

>From man gpg:

 --send-keys key IDs
Fingerprints  may  be used instead of key IDs. Option --keyserver must
be used to give the name of this keyserver. Don't send your com-
plete  keyring  to  a keyserver --- select only those keys which
are new or changed by you.
> I don't know why this happens as this is the email address I used when 
> creating the keypair and gpg printed that this address was part of my 
> User ID. I tried another command:

This happens because your command line indicated as argument your e-mail
address, that is your User ID, instead of the key ID, that is composed
by the last eight digits of the key's fingerprint.

As indicated above, you can use also the whole fingerprint.

> gpg --output  pubkey.myemail at mydomain.com.au.gpg.asc --armor --export 
> myemail at mydomain.com.au
> this worked and printed my public key to a text file. I have no idea why 
> it is not accepting my email as part of my user id when I try and send 
> keys to the keyserver.

As indicated above, because when sending to a keyserver, you have to
include the Key(s) ID, not your User ID (UID)

Best regards,

More information about the Gnupg-users mailing list