gpg.exe Vista Crash

Brian belstsrv at
Mon Feb 2 17:44:03 CET 2009

John Clizbe wrote:
> Brian wrote:
>> I downloaded 1.4.9 and installed it.  I then grabbed WinPT and when 
>> launching WinPT, I get repeated gpg.exe crashes, like I did before.
>> I also downloaded GnuPT and installed that, which comes with 1.4.9 and 
>> running that also causes gpg.exe crashes.
>> I then took all of the EXEs from w32cli install and copied them over to 
>> the GnuPT folder and had the same result.
>> I am really at a loss as to how to get a GUI interface to work with GnuPG.
>> What should I try next?
> Please QUIT installing add-ons until the program is working. You won't fix it by
> throwing more code at the problem.
> It sounds like your system is still finding the GPG4win binaries first.
> You may verify that by opening a command window (Start->Run-> cmd.exe click OK)
> then enter the command
>     gpg --version
> The first line of output should either specify 1.4.7 if the GPG4win code is
> found first, 1.4.9 otherwise. If it's 1.4.7, enter the command
>     path
> That will display the value of the PATH environment variable.
> C:\Program Files\Gnu\GnuPG\pub will likely occur before
> C:\Program Files\Gnu\GnuPG. That's what is causing your problem.
> To fix it, you may either edit the PATH value (Control Panel -> System ->
> Advanced -> Environment Variables)
> Perhaps the easiest would be to run both the GnuPG for Windows (GPG4Win) and
> GnuPG uninstallers. Then delete any files remaining in
> C:\Program Files\Gnu\GnuPG. Re-run the gnupg-w32cli-1.4.9.exe installer.
> Open a fresh command window and give the command 'gpg --version' again. It
> should report 1.4.9 as the version.
> I see you are using Thunderbird. Are you also wishing to use Enigmail for email
> OpenPGP use? If so, set it up npw and get it working next. If you already have
> keys, you do not need to generate a new key pair unless you just want to.
> Quick Start Guide:
> If you wish a separate GUI similar to PGP's most PGP users I know who have moved
> to GnuPG prefer GPGshell. Download and unzip the installer from
> I like to install GPGshell as a
> subdirectory under GnuPG (C:\Program Files\Gnu\GnuPG\GPGshell)

I removed everything and rebooted.  Then went and installed just the 
command line component.  The version shows as 1.4.9 and the path 
variable is correct.

I tried this command:
gpg -K

gog.exe crashed and the command line window give this info:
gpg: checking the trustdb
Assertion failed: keyblock->pkt->pkttype == PKT_PUBLIC_KEY, file 
keyring.c, line

This application has requested the Runtime to terminate it in an unusual 
Please contact the application's support team for more information.

Hopefully this will help troubleshoot this a little.  If there is 
anything I can do to debug or produce a log file, just let me know.

Thanks again.

More information about the Gnupg-users mailing list