installing gpg on Mandriva 2009

Chris cpollock at
Sat Jan 3 15:53:32 CET 2009

On Saturday 03 January 2009 05:59:26 Ingo Klöcker wrote:
> On Saturday 03 January 2009, Chris wrote:
> > On Friday 02 January 2009 20:39:04 Chris wrote:
> > > I've updated my Mandrake 10.1 box to 2009. On the 10.1 system gpg
> > > and gpg-agent were working smoothly.  I installed gnupg-2.0.9 from
> > > source and copied my old .conf files over to the .gnupg folder. I
> > > also installed kgpg. When trying to add my key in Kmail to Identies
> > >
> > > > Cryptography >OpenPGP Signing key the "fetching keys" bar
> > >
> > > continues to scroll back and forth without fetching anything. My
> > > key is on the key servers. My key is entered in the OpenPGP
> > > encryption key block already.  I had this working correctly in 10.1
> > > but it won't work now. I must be missing something. I have all the
> > > required libraries installed as well as pinentry-qt.  Any advice
> > > would be appreciated.
> > >
> > > Chris
> >
> > One other note on the above, gpg-agent appears not to be running at
> > least that's what Kmail says when it starts. Trying to run from the
> > cli gives me:
> >
> > [root at localhost ~]# gpg-agent
> > gpg-agent[24043]: can't connect to `/root/.gnupg/S.gpg-agent': No
> > such file or directory
> > gpg-agent: no gpg-agent running in this session
> Try whether you can start gpg-agent as daemon manually:
> # gpg-agent --daemon
> If this works then kill the gpg-agent process and start it with the
> command
> # eval "$(gpg-agent --daemon)"
> This will set the environment variable needed by all applications that
> want to make use of a running gpg-agent. Next start KMail from the same
> console, i.e.
> # kmail
> and check whether it works.
> If this works then put a file called into ~/.kde/env
> (or ~/.kde4/env) containing the following two lines:
> =====
> killall gpg-agent 2>/dev/null
> eval "$(gpg-agent --daemon)"
> =====
> This will ensure that gpg-agent is started whenever KDE is started.
> You can add more command line arguments to gpg-agent if you like. For
> example I added --default-cache-ttl 36000 to increase the duration
> gpg-agent caches the passphrase.
> Regards,
> Ingo
Starting as root worked so I then entered eval "$(gpg-agent --daemon)" and it 
now shows as a running process. Stopped and restarted Kmail, I did not get the 
warning that gpg-agent wasn't running this time which is good so I tried 
adding my signing key to the identies configuration. The 'fetchnig keys' 
scroll bar still just moves back and forth as if it can't find anything. I 
noticed that kgpg was running as 'chris' so I stopped the root gpg-agent and 
started as 'chris', I saw this:

[chris at localhost ~]$ eval "$(gpg-agent --daemon)"
can't connect to `/home/chris/.gnupg/log-socket': No such file or directory

gpg-agent shows to be running under processes though.

When running kmail as root and just setting up a quick identity when trying to 
fetch the keys there is no acitivty at all in the scrollbar

In the 'gpgagent' folder, which I copied over from my /home backup there is a 
'smime.log' file which contains these entries:

gpgsm[28176.0] DBG: -> # Home: ~/.gnupg
gpgsm[28176.0] DBG: -> # Config: /home/chris/.gnupg/gpgsm.conf
gpgsm[28176.0] DBG: -> # AgentInfo: [not set]
gpgsm[28176.0] DBG: -> # DirmngrInfo: [not set]
gpgsm[28176.0] DBG: -> OK GNU Privacy Guard's S/M server 2.0.9 ready
gpgsm[28176.0] DBG: <- OPTION display=:0.0
gpgsm[28176.0] DBG: -> OK
gpgsm[28176.0] DBG: <- OPTION enable-audit-log=1
gpgsm[28176.0] DBG: -> OK
gpgsm[28176.0] DBG: <- OPTION lc-ctype=(null)
gpgsm[28176.0] DBG: -> OK
gpgsm[28176.0] DBG: <- OPTION lc-messages=(null)
gpgsm[28176.0] DBG: -> OK
gpgsm[28176.0] DBG: <- OPTION list-mode=1
gpgsm[28176.0] DBG: -> OK
gpgsm[28176.0] DBG: <- OPTION with-validation=1
gpgsm[28176.0] DBG: -> OK
gpgsm[28176.0] DBG: <- LISTKEYS gnupg-users at
gpgsm[28176.0] DBG: -> OK
gpgsm[28176.0] DBG: <- BYE
gpgsm[28176.0] DBG: -> OK closing connection

My gpg.conf file is:

default-key  441D71BC727D0B1CEC1F6B39E372A7DA98E6705C
default-cert-check-level 3

The gpg-agent.conf file is:

pinentry-program /usr/bin/pinentry-qt
default-cache-ttl 3600
debug-level advanced
log-file socket:///home/chris/.gnupg/log-socket

More information about the Gnupg-users mailing list