recover private key

jakse jacobbjerrum at
Sat Jan 10 11:14:20 CET 2009

Thanks so much! i really think it worked

Faramir-2 wrote:
>   *I think* there is a good chance it is what you need. GnuPG uses the
> files secring.gpg and pubring.gpg to store the private and public keys.
> But the .ASC file extension is used to store files as "armored ascii"
> format, which can be opened as a text file, printed, etc. But the
> content of an .ASC file is still the same content it would have if it
> was stored as .GPG (I mean, the format doesn't remove the info).
you where right! i did cat secring.asc and it returned my private key!

Faramir-2 wrote:
> I think the command you need is:
> gpg --import secring.asc
That was the right command i think!!


does anyone have the time to test it with me? see - i'm kinda of semi nerdy
and really dont know anyone who sends encrypted files... i justed wanted
this stuff to work so that i have the skill and posibility to use it when it
is needed!


ps: i did get some warnings on the way, dont know what it really means -
dont hope the secring.asc file was just a "demofile" of some sort?!

gpg: WARNING: key ECABF51D contains preferences for unavailable
gpg:          algorithms on these user IDs:
gpg:          "Test three (no pp) <three at>": preference for
cipher algorithm 1
gpg: it is strongly suggested that you update your preferences and
gpg: re-distribute this key to avoid potential algorithm mismatch problems

View this message in context:
Sent from the GnuPG - User mailing list archive at

More information about the Gnupg-users mailing list