gpg-agent rejects correct password for ssh keys

Michal 'vorner' Vaner vorner at
Fri Feb 26 17:20:34 CET 2010

Good morning

I have trouble with gpg-agent and its --enable-ssh-support. When I start it
(for test by eval `gpg-agent --daemon --sh --enable-ssh-support`), I add my ssh
key by ssh-add. It first asks for a passphrase of the key (in console), then
gpg-agent asks for a new passphrase to store the key encrypted (by
pinentry-gtk). I type it, retype it and try to ssh somewhere.

The agent asks for a passphrase to decrypt the key. I type it again and, this is
the problem, it says it is incorrect. I'm sure I typed it correctly (I tried
several times the whole procedure, deleting the key and sshcontrol key between
attempts), I even tried with empty passphrase.

The key works fine with ssh-agent.

This is its --version output:

gpg-agent (GnuPG) 2.0.14
libgcrypt 1.4.5

I tried to use google, but it doesn't seem to give me any reasonable results.
Could anyone point me in the right direction how to investigate what is wrong? I
tried to get some debug output from the agent, but it either goes background or
does not print the environment variables no matter which combination of
--server, --daemon, --no-detach, --debug I tried.

What do I do wrong?

Thank you

Have you ever been told you are an airplane?

Michal 'vorner' Vaner
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: </pipermail/attachments/20100226/07c09866/attachment.pgp>

More information about the Gnupg-users mailing list