Using pinentry-curses interactively in Linux boot process fails (SOLVED)

Malte Gell malte.gell at
Fri Jul 23 08:52:07 CEST 2010

Grant Olson <kgo at> wrote

> On 7/22/10 6:13 PM, Malte Gell wrote:
> > Hi there!
> >
> > I have the following setup: a Linux luks encrypted partition. It is
> > encrypted with a keyfile, the keyfile itself is GnuPG encrypted and
> > stored in /root
> ...
> > When I use these commands after booting, they do what I want them to do.
> > pinentry-curses asks my PIN, I enter it and everything is fine. But when
> > I use exactly these commands in my script, I simply get no
> > pinentry-curses appearing on the screen...
> Are all the files for gpg2 on your boot partition? 

Yes and the boot partition is not encrypted, only /home But I solved it. It 
was an init script issue. On openSUSE there is an init script "earlyxdm" and 
it has overridden so to say the pinentry-ncurses program. I have now edited 
earlyxdm and have added my own script to Requried-Start, thus earlyxdm now 
waits until pinentry-curses does its job. It works now. Pretty cool, I can now 
unlock my LUKS volume with the openPGP card, that's nerd ;-)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 316 bytes
Desc: This is a digitally signed message part.
URL: </pipermail/attachments/20100723/f456f127/attachment-0001.pgp>

More information about the Gnupg-users mailing list