Can't use GPG key - secret key not available

Chris Ruff jcruff at
Sat Oct 2 05:18:34 CEST 2010

The long key id can be view with the command: 

gpg --list-keys --keyid-format long <keyid>

Chris Ruff
email: jcruff at
gpg key: 0xBDD5B810
gpg fgpr: 1BA1 71D7 ADA7 1E8B 1623
          A43D 283B 2F81 BDD5 B810

-----Original Message-----
From: Madhusudan Singh <singh.madhusudan at>
To: gnupg-users at
Subject: Re: Can't use GPG key - secret key not available
Date: Thu, 30 Sep 2010 10:40:21 -0500

It did not work. I still get the same error as before.

I somehow doubt that this suggested solution would work, but how do I
get the 16 last characters ? I remember seeing it when it was generated.

On Thu, Sep 30, 2010 at 8:53 AM, Charly Avital <shavital at> wrote:
        Noiano wrote the following on 9/30/10 3:48 AM:
        > Hi,
        > check your gpg.conf. You should have a "default-key" parameter
        set. I
        > have "default-key AB10E8D2".
        > Hope this helps.
        > Noiano
        If the above does not help, try using the long key ID, 16 last
        characters (instead of 8) of the key's fingerprint.
        MacOS 10.6.4-MacBook Intel C2Duo 2GHz-GnuPG 1.4.10-MacGPG 2.0.14
        Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US;
        Gecko/20100802 Thunderbird/3.1.2 - Running Enigmail version

Gnupg-users mailing list
Gnupg-users at

More information about the Gnupg-users mailing list