Crontab running gpg script can’t find secret key

griffmcc gmcclellan at
Thu Feb 3 00:29:49 CET 2011

Although I can encrypt a file using a script, when crontab runs the same
script, it returns the error message “no default secret key: No secret key”.

I have one secret key:

sananselmo backupscripts.d # gpg --list-secret-keys
sec   2048R/AC1E8E28 2011-01-11
uid                  Griff McClellan (Broadmark Asset Management) 
ssb   2048R/81E9591C 2011-01-11

Here is my script:

gpg -vvv --batch --output /usr/share/tararchive/file.gpg --encrypt –sign

When I run it I am prompted for a password, even though I have the batch
flag.  However the file.gpg encrypted file is created.

When I run the same script as root using crontab, I get:

gpg: no default secret key: No secret key

Does anyone have any suggestions about how to fix this problem?  I tried
setting the default-flag in gpg.conf but that didn’t change the outcome.

View this message in context:
Sent from the GnuPG - User mailing list archive at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/attachments/20110202/039de8e3/attachment.htm>

More information about the Gnupg-users mailing list