Crontab running gpg script can’t find secret key

David Smith Dave.Smith at
Thu Feb 3 14:31:38 CET 2011

griffmcc wrote:
> Although I can encrypt a file using a script, when crontab runs the same
> script, it returns the error message “no default secret key: No secret
> key”. I have one secret key:
> sananselmo backupscripts.d # gpg --list-secret-keys
> /root/.gnupg/secring.gpg
> ------------------------
> sec   2048R/AC1E8E28 2011-01-11
> uid                  Griff McClellan (Broadmark Asset Management) 
> ssb   2048R/81E9591C 2011-01-11
> Here is my script:
> gpg -vvv --batch --output /usr/share/tararchive/file.gpg --encrypt –sign /usr/share/tararchive/file.tar.bz2
> When I run it I am prompted for a password, even though I have the batch
> flag. However the file.gpg encrypted file is created. When I run the
> same script as root using crontab, I get:
> gpg: no default secret key: No secret key
> Does anyone have any suggestions about how to fix this problem? I tried
> setting the default-flag in gpg.conf but that didn’t change the outcome.

Which user ID is the cron script running under?  Is that user the same
one that owns the key?

More information about the Gnupg-users mailing list