Error messages when generating new keys

Olivier N. onemailid4mailinglists at
Wed Jul 6 15:30:36 CEST 2011

Hello Werner,

>> 2. I tried  "$ gpg2 --gen-key", chose default options
>>     and entered my infos (email address, name,…)
>>     and I got:
>>        gpg: problem with the agent: Bad CA certificate
>>        gpg: problem with the agent: Invalid card
>>        gpg: Key generation canceled.
> You are either running a version of gpg-agent which is too old or gpg
> started that version of gpg-agent but expected another one.  Or there is
> another daemon taking over the connection between gpg2 and gpg-agent.
> Seahorse as well as the gnome-keychain(?) used to do this (which is
> something they should not do).
> Adding the options "--verbose --debug 2048" to the command line may give
> you some more insight.  Make sure all gpg-agent's are stopped.

I modified a lot my Linux box these last few days:
upgrades, new WM (ratpoison instead of gnome) and so on.

I then tried gpg2 again and I have no error message anymore.
Great! Even though I have no idea what solved my problem.

In a few days, I'll have to install it and use it on
computers running Windows. Hope everything will run fine.

Thanks again,


More information about the Gnupg-users mailing list