gpgkeys: HTTP post error 7: couldn't connect: Not found

Ђорђе Тодоровић postmanmiler at
Sun May 1 20:10:27 CEST 2011

Newb here. My machine is having problems reaching keyservers unless they are specified
with their IP address. I can't resove hkp://* hostnames and I also can't reach ldap
servers either. (I compiled my gpg with ldap support but it says:
   gpgkeys: protocol `ldap' not supported
   gpg: no handler for keyserver scheme `ldap'
   gpg: keyserver search failed: Keyserver error
so I can't reach them too.)

I am using:
   gpg (GnuPG) 2.0.17
   libgcrypt 1.5.0-beta1

I am not behind a proxy, the other (Windows) computer that is on the same network as me is
reaching servers normal (so, it's probably not a router problem) and I tried reaching
several different servers (well, I tried all the servers that i found) and still no luck
on this machine.

When I try to upload my keys using:
   gpg --keyserver hkp:// --send-keys 1E133339

this is the error that I am getting:
   gpg: sending key 1E133339 to hkp server
   : can't connect to `': host not found
   gpgkeys: HTTP post error 7: couldn't connect: Not found
   gpg: keyserver internal error
   gpg: keyserver send failed: Keyserver error

When that failed I tried this:
   gpg --keyserver-options "honor-http-proxy broken-http-proxy" --keyserver \
   hkp://  --send-keys 1E133339
I'm running Gentoo Linux 64bit and 2.6.38 kernel (with hardened patches).
I tried using different DNS nameservers, but still, my machine doesn't know how to resolve
hkp hostnames.

  . O . | Djordje Todorovic [aceofknaves at G_M_A_I_L .com] | O . O
  . . O | GPG-Key: 2048R/1E133339    (   | . O O
  O O O | BFF2 1C7F A70D ECCD FA8F C946 DB32 B498 1E13 3339 | . O .
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 490 bytes
Desc: not available
URL: </pipermail/attachments/20110501/dd8298f2/attachment.pgp>

More information about the Gnupg-users mailing list