Problem with the pgp to gpg key migration

Pramod.R Pramod.R at
Mon May 9 14:43:06 CEST 2011


I tried migrating the public and the private key from the pgp(6.5.8) keyring to the gpg(1.4.11) by following the below commands:

1)      Tried exporting the private and the public key from pgp using the commands:
pgp -kx " " pubkey.pgp
                                pgp -kx " " sec.pgp ~/.pgp/secring.skr

2)      Tried importing these two keys into the gpg using the below commands:
gpg --import pubkey.pgp
gpg --allow-secret-key-import --allow-non-selfsigned-uid -import sec.pgp

3)      When I tried comparing the pgp keyring with the newly created gpg keyring (using the commands: gpg --list-key), I found that all the keys have been migrated except two of my self-generated pgp keys.

4)      When I also tried encrypting a plain text using pgp using my self-created pgp and then decrypting this using the gpg (after migrating the keyring as explained above), I got an error saying that gpg: decryption failed: secret key not available, which obviously because I cannot see my own keys in the new gpg keyring.

Please let me know if I'm missing anything here. Also do let me know if the above problem makes any sense or if you would need any other information.

Warm Regards,
Pramod R | Analyst, BI | FRS- Decision Systems & Support | *Target Corporation India | Bangalore| +91 988 630 0519 | +91 804 017 2416

-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/attachments/20110509/76b34e1b/attachment.htm>

More information about the Gnupg-users mailing list