Trying to create auth key on GPF CryptoStick

Martin Gollowitzer gollo at
Mon Jan 2 09:01:44 CET 2012

* Paul Hartman <paul.hartman at> [120102 08:52, 
  mID <CAEH5T2O4HFyOFTKi8Bm16gXwcZhBpTmVQz7NQiQBW3yKmh5_LA at>]:

> Hi,
> I got a GPF CryptoStick 1.2 yesterday and have successfully added my
> new signing and encrypting subkeys to the card using GPG 2.0.18 and
> using it without trouble so far for those purposes. However, when I
> tried to create an authentication key it gives this error twice:
> gpg: key generation failed: Card error
> gpg: Key generation failed: Card error
> To get there, I ran "gpg --edit-key <my keynum>", then "addcardkey"
> command, chose Authentication key, 4096 keysize, enter the requested
> PINs and passphrase, but it results in the error above.
> It is likely I'm doing something wrong, but am not sure what... if
> someone has any clues, it is appreciated if you can point me in the
> right direction.

Even v2 cards can't carry 4096 Bit keys. The maximum size is 3072 Bits

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 490 bytes
Desc: not available
URL: </pipermail/attachments/20120102/31a86fa6/attachment.pgp>

More information about the Gnupg-users mailing list