Please help! (Alastair Langwell)

Alastair Langwell sonofbelial at
Wed Mar 7 09:19:41 CET 2012

Thanks to you and Robert for getting back to me. However this
unfortunately didn't solve the problem. I ran:

chown alastair:alastair ~/.gnupg/


chown alastair:alastair ~/.gnupg/*

Then I tried root:alastair and alastair:root but still no go.

Any other ideas? In the meantime, I'll try and chown each file in
~/.gnupg individually and see if that changes anything.

Incidentally, when I chown'ed everything in the folder, gnupg gave a
warning when I ran it in the terminal:

WARNING: unsafe ownership on configuration file

Thanks in advance for helping me solve this.

Key: E2F6 3C0F 21BB 5DEB 32BF AC52 CA72 33EC 302F 21A8

Reid Thompson wrote:
> On 3/6/2012 8:03 PM, Alastair Langwell wrote:
>> Hi folks,
>> I wonder if any of you can help with this problem
>> (
>> on Enigmail? I'd appreciate it and promise I'll post any solutions into
>> that forum thread!
>> Many thanks in advance,
>> Alastair Langwell
>> Key: E2F6 3C0F 21BB 5DEB 32BF AC52 CA72 33EC 302F 21A8
>> _______________________________________________
>> Gnupg-users mailing list
>> Gnupg-users at
> |~/.gnupg/ and all the files  it contains are owned by root --  they
> should be owned by you
> chown the directory and it's contents to be you and your primary group
> |

More information about the Gnupg-users mailing list