Please help! (Alastair Langwell)

Peter Lebbing peter at
Wed Mar 7 12:26:21 CET 2012

On 07/03/12 09:19, Alastair Langwell wrote:
> Thanks to you and Robert for getting back to me. However this
> unfortunately didn't solve the problem. I ran:
> chown alastair:alastair ~/.gnupg/
> and
> chown alastair:alastair ~/.gnupg/*
> Then I tried root:alastair and alastair:root but still no go.

Define "no go". What are the actual error messages when you chown? And also, do
you use root to chown? Because you need to.

Finally, you don't have execute set in the permissions for the directory. I can
only imagine this is also by accident, and it should be set. "Execute" on a
directory means the right to descend into that directory. Now only root can get
into the directory (because root can do whatever he likes, not because of how
the permissions are set).

For reference, here's a redacted version of my directory:

peter at tweek:~$ ll -a .gnupg
total 7672
drwx------   3 peter peter    4096 Mar  7 12:14 .
drwxr-xr-x 121 peter peter   12288 Mar  7 11:15 ..
-rw-r--r--   1 peter peter      19 Nov 29  2009 gpg-agent.conf
-rw-------   1 peter peter     183 Jan 31 14:13 gpg.conf
drwx------   2 peter peter    4096 Dec  8  2009 private-keys-v1.d
-rw-------   1 peter peter 3870766 Feb 17 10:31 pubring.gpg
-rw-------   1 peter peter 3870766 Feb 17 10:31 pubring.gpg~
-rw-r--r--   1 peter peter      15 Dec 18  2009 scdaemon.conf
-rw-------   1 peter peter   11282 Feb  7 13:03 secring.gpg
-rw-------   1 peter peter    9840 Feb 17 10:31 trustdb.gpg

Particularly note the drwx------ on the directory itself.


I use the GNU Privacy Guard (GnuPG) in combination with Enigmail.
You can send me encrypted mail if you want some privacy.
My key is available at

More information about the Gnupg-users mailing list