gpgee operation failed

Henry Hertz Hobbit hhhobbit at
Mon Apr 29 17:34:23 CEST 2013

On 04/29/2013 03:39 AM, 儒風管理部-潘右文 wrote:
> Hi there ,
> Can someone help me with this error?
> I reinstalled the program ,  and encrypt the file again, still don’t work.
> I used to encrypt file without any issue.  My program version is 1.1.4.
> Thanks.

Are you saing it used to encrypt but stopped encrypting before you
installed the GPG4Win 1.14 again?

Oops.  I should not have spoke up so fast.  I didn't have time to
load GPG4Win, 7-Zip, Firefox, and a lot of other stuff for Windows.
Even worse I haven't had time to tame Windows Explorer to show some
folders. extensions, use lists, etc.  I have that partially done now.

1.1.4 is pretty old and the new GPG4Win 2.10 has worked just
fine for me on both Windows XP Home / Pro and now on Windows
7 Pro (remember, I just installed it, Firefox, and 7-Zip).
Your pictures shows that the validity of the key is unknown.
Have you signed it? But the way you said things sounded like
it was working that way (it should).

I just loaded GPG4Win 2.10 on Windows 7 Pro.  I could not see
where it put things so I generated dummy keys to find the
location.  I found them here:


I deleted the files (keeping random_seed) and then copied my files
from Linux (w/o random_seed) into the folder. I have 32 bit LE
throughout, although Linux is set up with PAE so I can exceed the
3 GB memory barrier. GPG4Win 2.10 uses the newer gpgex and
Kleopatra.  Encrypting the file was easy though.  All I had to do

1. Right click on a Firefox.txt file in Windows Explorer
2. Select encrypt from GPG4Win menu
3. Select a proper recipient (I picked me)
4. Let it encrypt it.

I moved the encrypted file onto a flash drive and decrypted it
on another Linux system.  It decrypted fine with me supplying
my pass-phrase.  I tried an additional test of another recipient
and it could NOT be decrypted which is to be expected.  I don't
have their private keys or know their pass-phrase.

I am trying to think of what could be going wrong.  When you
installed the program again did you still have your exisiting
keys?  You should.  I have upgraded through several versions
of GPG4Win with no problems.  In fact I haven't had any problems
at all on Windows.  Encrypting on OpenSuse 11.4 via GPG
(symmetric or public key) may be impossible.  I now use 7-Zip
with it's bundled AES-128 for symmetric encryption on OpenSuse
and to transfer files back and forth with another Linux system.

Unless it is a damaged key-ring (in which case, why could you see
anything?) I see no reason why you can not just upgrade to
GPG4WIN 2.10 and go from there:

You have ALL the information including where you may need to
move your keys if you have moved from Windows XP to Windows 7.
Hopefully you don't have Vista.  If you do I don't know
where the files go if you have to move / copy them.


More information about the Gnupg-users mailing list