gpg: out of memory while allocating 8192 bytes - HELP NEEDED

raja aditya sradithya at
Sun Jan 20 04:17:37 CET 2013

Hi All,

We are receiving the below error message when trying to encrypt or decrypt
a file on AIX server :

*gpg: out of memory while allocating 8192 bytes*

gpg process was working for years on the server until the day we started to
see this.

This same gpg encryption is working on an other AIX server in the same
environment. Many options were tried including copying the gpg from the
server that's working on, recycling the server etc. But the error is

This is not a problem with any one specific id or a group of id's. Any id
trying to encrypt/decrypt is getting this error. Hence this is observed at
a server level and not at a user or id level.

We have an other server with identical settings where it is working
normally. Even restoring the file system from this server didn't help.

The server memory is just fine and is well within limits. Even trying to
encrypt / decrypt an empty or a 3 record file is facing a problem, hence
its irrespective of the file size or who is trying to encrypt/decrypt it.

Sample Error :

/home>touch simple1
/home >chmod 777 simple1
/home >/opt/TWWfsw/gnupg12/bin/gpg --encrypt-file simple1
You did not specify a user ID. (you may use "-r")

Enter the user ID. End with an empty line: sradithya
*gpg: out of memory while allocating 8192 bytes*
/home >

The issue that surprises is that it also worked for a day after the crash
recovery. Its only the next day that it stopped working.

No visible changes happened in that one day nor any new file systems were
restored. The fact that it worked for a day after crash and then lost is

Any help or suggestions on this or any clues to look out for would be of a
invaluable help to me. Please post any suggestions that you may have.

Best Regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/attachments/20130119/67ecee2a/attachment.htm>

More information about the Gnupg-users mailing list