Help needed

david at david at
Fri Nov 14 01:12:24 CET 2014

On 13/11/14 22:42, Hauke Laging wrote:
> Am Do 13.11.2014, 22:33:31 schrieb david at
>> I exported my keys to a USB stick. Then I copied my .gnupg to a new
>> Linux laptop. Then I imported my keys. I thought that I would be
>> fine.
> It is unclear to me what exactly you are talking about.
> The terms "export" and "import" usually refer to the commands
> gpg --export[...]
> gpg --import
> But it also sounds like you have copied the whole directory ~/.gnupg/
> If you have copied the directory then maybe the file permissions have 
> not been preserved. Check whether secring.gpg has 600. And delete the 
> file random_seed.
> If you have exported and imported instead then you are missing the trust 
> database. You should either copy trustdb.gpg or export and import this 
> data, too:
> gpg --export-ownertrust
> gpg --import-ownertrust
> Hauke

I have my trustdb.gpg

And I still get the same error message. Perhaps the correct question to ask is:

"How do I transfer ALL files in my .gnupg onto another Linux laptop so that ALL functions
work as before - i.e it works the same on both machines.

I hope that is within the bounds of your understanding.


“See the sanity of the man! No gods, no angels, no demons, no body. Nothing of the
kind.Stern, sane,every brain-cell perfect and complete even at the moment of death. No
delusion.” -
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0xAAD8C47D.asc
Type: application/pgp-keys
Size: 4295 bytes
Desc: not available
URL: </pipermail/attachments/20141114/ed5da4f4/attachment.key>

More information about the Gnupg-users mailing list