Help needed

david at david at
Fri Nov 14 10:45:14 CET 2014

On 14/11/14 04:11, Daniel Kahn Gillmor wrote:
> Hi David--
> You sound frustrated.  hopefully we can help you figure things out.
> Some of the details of what's happened on your machine(s) sound unclear
> to me, and we'll be able to help you better with more precise information.
> On 11/13/2014 04:31 PM, david at wrote:
>> Even when I use a backup programme and restore I still get the same error message.
> What backup program did you use?  What version of gnupg were you using
> on your old computer?  what platform was your old machine?  what
> platform is your new machine?
> If you feel comfortable sharing any of this information, i'd be curious
> to see the outcome (on both old and new machines) of any of the
> following series of commands:
>  uname -a
>  ls -la ~/.gnupg
>  gpg --version
>  gpg --list-secret-keys 0xAAD8C47D
>  echo test | gpg --clearsign -u 0xAAD8C47D
> If it looks like this information is too sensitive to post to the list,
> but you feel ok sending it to me privately, you're welcome to send it to
> me privately (my OpenPGP fingerprint is at the bottom of this mail if
> you wish to encrypt it).
>> So no-one
>> has ever copied their .gnupg folder to another laptop. No one has ever done this with any
>> success.
> I can say based on personal experience that this is not the case.  I
> have done several such transfers, for myself and for other people.
>> You have all failed. Clearly there's something wrong with gnupg that does not like
>> being backed up copied whatever. If it were another programme say Thunderbird no one would
>> use Thunderbird. They would say Thunderbird was crap.
> I'm going to treat this paragraph as you expressing your frustration,
> instead of reading it as an attack on the developers of GnuPG.  Other
> people might read it differently, and may find it demotivating in terms
> of helping you with your current situation.
> Please remember that there are human beings on the other side of your
> e-mail, people who are remarkably committed to helping others, but who
> also have their own feelings.
> Regards,
> 	--dkg
> OpenPGP Fingerprint: 0EE5BE979282D80B9F7540F1CCD2ED94D21739E9
Hi Daniel,

Firstly I can neither encrypt or sign. I have two laptops (1) 32 bit LXD (2) 64 bit LXD my
64 bit machine crashed and went off for repairs. It came back I reinstalled the operating
system and all programmes - now a mirror image of my 32 bit LXD. Then I did the following:

(1) david at laptop-1:~$ gpg
gpg: directory `/home/david/.gnupg' created
gpg: new configuration file `/home/david/.gnupg/gpg.conf' created
gpg: WARNING: options in `/home/david/.gnupg/gpg.conf' are not yet active during this run
gpg: keyring `/home/david/.gnupg/secring.gpg' created
gpg: keyring `/home/david/.gnupg/pubring.gpg' created
gpg: Go ahead and type your message ...

(2) Run ALL your GUIs eg Kgpg Kleopatra GPA - but do not create a new set of keys! Kgpg will
complain and not run.

(3) Reboot your system - very important!

(4) Type david at laptop-1:~$ gpg-agent
gpg-agent: gpg-agent running and available
david at laptop-1:~$

Then I copied ALL .gnupg files from the 32 bit laptop to the 64 bit laptop - on the 32 bit
laptop I exported my keys saving them to a file - I did this twice. Then I imported my keys
into the 64 bit laptop. All programmes see my key - even gpg but I always get the same error
message: "Key 0xAAd8C47D not found or not valid. The (sub-)key might have expired" when I
try to sign or encrypt a message.

Now insted of copying ALL the files from one .gnupg to another am just going to copy
secring.gpg and trustdb.gpg - then import my keys - if this works then you will know how to
do it in the future - if it does not work - hmmmmmmm...............


“See the sanity of the man! No gods, no angels, no demons, no body. Nothing of the
kind.Stern, sane,every brain-cell perfect and complete even at the moment of death. No
delusion.” -

More information about the Gnupg-users mailing list