Help needed

Daniel Kahn Gillmor dkg at
Fri Nov 14 05:11:02 CET 2014

Hi David--

You sound frustrated.  hopefully we can help you figure things out.

Some of the details of what's happened on your machine(s) sound unclear
to me, and we'll be able to help you better with more precise information.

On 11/13/2014 04:31 PM, david at wrote:
> Even when I use a backup programme and restore I still get the same error message.

What backup program did you use?  What version of gnupg were you using
on your old computer?  what platform was your old machine?  what
platform is your new machine?

If you feel comfortable sharing any of this information, i'd be curious
to see the outcome (on both old and new machines) of any of the
following series of commands:

 uname -a
 ls -la ~/.gnupg
 gpg --version
 gpg --list-secret-keys 0xAAD8C47D
 echo test | gpg --clearsign -u 0xAAD8C47D

If it looks like this information is too sensitive to post to the list,
but you feel ok sending it to me privately, you're welcome to send it to
me privately (my OpenPGP fingerprint is at the bottom of this mail if
you wish to encrypt it).

> So no-one
> has ever copied their .gnupg folder to another laptop. No one has ever done this with any
> success.

I can say based on personal experience that this is not the case.  I
have done several such transfers, for myself and for other people.

> You have all failed. Clearly there's something wrong with gnupg that does not like
> being backed up copied whatever. If it were another programme say Thunderbird no one would
> use Thunderbird. They would say Thunderbird was crap.

I'm going to treat this paragraph as you expressing your frustration,
instead of reading it as an attack on the developers of GnuPG.  Other
people might read it differently, and may find it demotivating in terms
of helping you with your current situation.

Please remember that there are human beings on the other side of your
e-mail, people who are remarkably committed to helping others, but who
also have their own feelings.



OpenPGP Fingerprint: 0EE5BE979282D80B9F7540F1CCD2ED94D21739E9

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 949 bytes
Desc: OpenPGP digital signature
URL: </pipermail/attachments/20141113/9c8adacc/attachment.sig>

More information about the Gnupg-users mailing list