Why the software is crap

Tristan Santore tristan.santore at internexusconnect.net
Fri Nov 14 13:41:12 CET 2014

On 14/11/14 13:24, david at gbenet.com wrote:
> On 14/11/14 11:55, Martin Behrendt wrote:
>> Am 14.11.2014 um 12:41 schrieb david at gbenet.com:
>>> Hello All,
>>> I even tried exporting my private and public key from the command line and then tried
>>> importing. The same error message as before. I have checked on the internet - most of the
>>> suggestions are crap - the authors have never ever tried to do what they suggest others to
>>> do. If they had done so then they would have known just how crappy their supposed expertise was.
>>> I have even looked through https://www.gnupg.org/faq/GnuPG-FAQ.html  and found this to be a
>>> useless pile of crap also.
>>> I am faced with two options:
>>> (1) Create yet another set of keys
>>> (2) Give up using gnupg after some 20 years
>>> I think I will unsubscribe from this list and give up on gnupg as a pile of crap.
>>> David
>> I think unsubscribing is the best thing you can do. Because you probably
>> successfully destroyed the good intension and motivation of anyone
>> helping you, with the offending nonsense you wrote in your last mails.
>> If you are angry just shut up and write again after you cooled yourself
>> down. The problem is more likely with you because there are not many
>> people reporting such problems.
>> And I can tell from my own experience that it is not even a problem
>> copying the content of the gnupg directory between windows and linux.
>> Tried that successfully.
>> Maybe you should read the FAQ again (and try to understand what is
>> written). Maybe there is a difference between exporting the public part
>> of a key and the private part.
>> Anyway, enjoy your life.
>> Martin
>> _______________________________________________
>> Gnupg-users mailing list
>> Gnupg-users at gnupg.org
>> http://lists.gnupg.org/mailman/listinfo/gnupg-users
> Martin,
> I have cooled. You can export your private key - you can export your public key. You can
> import your private key you can import your public key. In 20 years I have always had the
> same problem - the same error message and have each time created a new set of keys. I have
> done this 4 times.
> I notice that no one on this list - for all the talk of "oh I've done it" can offer no
> practical information has to HOW. No one. No one. No one knows how to do this simple task.
> In all my 20 years I have never found out how. Perhaps things are different under a Windows
> O/S but on Linux there is NO SOLUTION.
> Perhaps the only "solution" is to import ones private and public keys and lose all your
> contacts - ie a brand new installation. But I repeat BUT no one has ever created a mirror
> image of a .gnupg and had a fully 100 per cent working signing and encryption functionality.
> No one. There are no real practical solutions written anywhere on the internet.
> There is nothing of any value in  https://www.gnupg.org/faq/GnuPG-FAQ.html - there never was
> in all the 20 years of reading it.
> Sure you can moan criticise me for my getting frustrated - and you can all moan and cringe
> You are offended? Why? It is an easy thing to do is it not to moan about what and how people
> express themselves - yet you completely ignore the real issue. You ignore is because you can
> offer no real meaningful solution. As I have said no one has ever successfully transferred
> their public and private keys between machines and got them to successfully work. That's a
> real fact. And no one on this list as any practical solutions that work in the real world.
> That's a fact. The fact is no one on this list has ever done it with 100 per cent success.
> That's a fact. There is no practical advice on the internet. That's a fact.
> David

I am pretty sure I have seen advice on how to backup and restore your 
keys, if not on this list, in the countless smartcard how to.

I must admit I have not followed previous threads from you, but you must 
admit and be fair, that generally most people here are friendly and 
supportive. But I have seen the topic come up a few times, so maybe this 
is a security versus usability issue ? But again, I have not followed 
exactly what your problem is. Just wanted to point out that most people 
are reasonably helpful and friendly. Labelling gnupg as crap is, not 
exactly a fair assessment I think, and falls within the lines of 
labelling selinux crap, because people do not understand it/are confused 
by what is going on.

Anyway. I hope you work it out in the end and I am sure, somebody will 
be willing yo nudge you in the right direction.



Tristan Santore BSc MBCS
Network and Infrastructure Operations
Mobile +44-78-55069812
Tristan.Santore at internexusconnect.net

Former Thawte Notary
(Please note: Thawte has closed its WoT programme down,
and I am therefore no longer able to accredit trust)

For Fedora related issues, please email me at:
TSantore at fedoraproject.org

More information about the Gnupg-users mailing list