question about gpg2 and passphrase

Andrey Utkin andrey.od.utkin at
Thu Dec 3 00:18:23 CET 2015

On 02.12.2015 22:12, Smith, Cathy wrote:
> I need to be able to decrypt a file using gpg2 in batch.  I have a
> customer who requires us to provide a public  key that is  RSA 2048 bit.
>  I have RHEL6 available which provides gpg 2.0.14 to create the key
> pair.  However,  I’ve not been able to use gpg2 in batch to provide the
> passphrase to decrypt a file.  It wants an interactive prompt for the
> passphrase.  I’ve tried some things that I’ve read on-line without any
> success.    Is there a way to configure gpg2 to accept a passphrase in
> batch?

Have you tried generating a key with empty passphrase?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: </pipermail/attachments/20151203/a16492b5/attachment.sig>

More information about the Gnupg-users mailing list