GPA - unsupported certificate

david at david at
Mon Dec 7 01:24:55 CET 2015

On 05/12/15 19:33, Dark Penguin wrote:
> I wanted to report a few bugs in GPA that I've been getting on Debian Squeeze, but I thought
> I should check if they still exist in the latest version. So, I've installed Debian Jessie
> and got the latest release (0.9.9) to see if there was any improvement since few years ago.
> So, I start "gpa". The first thing I see is the Key Manager window and an invitation to
> create a new key. On top of it, an error message ("Unsupported certificate") pops up
> immediately; on top of this message, "GnuPG is rebuilding the trust database", which "might
> take a few seconds", but takes forever.
> I tried to wait, but in the end I just had to close the "trust database" popup and the
> "Unsupported certificate" error message. then I proceeded with generating a new key, and
> made sure all those old bugs are still there. And what's more, every time I open the Key
> Manager window, the "Unsupported certificate" error pops up again, and there are no keys in
> the Key Manager. Not even the one I've created.
> Are those really bugs or am I doing something wrong?.. I've tried that on an Ubuntu 14.04
> LTS livecd right after booting it up, to see if it works on one of the most popular
> distributions, but all the problems were exactly the same.
> So, the problems are there on Debian Jessie with 3.16 kernel, gpa 0.9.5/0.9.9 and gpg
> 1.4.18/2.0.26 and Ubuntu 14.04 LTS with 3.19 kernel, gpa 0.9.4-1 and gpg 1.4.16/2.0.22. (I
> didn't upgrade Ubuntu before trying. Also, seems like GPA uses the gpg2-branch, but does it
> really call upon gpg2 and not old gpg, which is hardly possible to remove from the system
> without breaking a LOT of dependencies like APT?..) Should I go on and submit all those
> things as bug reports, or am I missing something important here?.. Seriously, things don't
> work out of the box and nobody has even noticed?.. I just have a hard time believing it...
Hi Dark Penguin,

The first thing to say is - when installing any Linux distro you need to ensure that the
distro has installed every software update every security fix first. This is important when
installing GPA Kleopatra and KGPG.

Every Linux distro has gnupg installed - so at a terminal just type gpg - this will create
ALL the folders and files needed (.gnupg) it's pointless installing GPA without running gpg
first - I think it's pretty silly.

Then you may wish to install gpgv2 via the package manager. Only then install GPA Kleopatra
or KGPG. And only after installing all the updates and security fixes.

Once you have done this you can use any of the packages to create a set of keys - GPA
Kleopatra or Kgpg.

There are no bugs in GPA - all these programmes expect to find a valid existing .gnupg


There are no bugs in GPA

“See the sanity of the man! No gods, no angels, no demons, no body. Nothing of the
kind.Stern, sane,every brain-cell perfect and complete even at the moment of death. No
delusion.” -

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 884 bytes
Desc: OpenPGP digital signature
URL: </pipermail/attachments/20151207/2264ac3a/attachment.sig>

More information about the Gnupg-users mailing list