upgrading v1 to v2
dave.kimble at riseup.net
Thu Mar 26 03:39:44 CET 2015
Ubuntu 14.04 with gnupg 1.4.16 installed from Ubuntu repository.
Enigmail says it is about time I upgraded to gnupg v2.
Ubuntu Software Centre says I have the latest version.
I have git cloned gnupg ?v2.0.26? and attempted to configure.
It says I need libgpg-error, libgcrypt, libassuan, libksba, npth
I have installed libgpg-error-1.9 , apparently OK.
I can see /usr/lib/bin/libgpg-error and /libgpg-error-config
When I try to configure libgcrypt-1.6.3 it says:
checking for gpg-error-config... /usr/local/bin/gpg-error-config
checking for GPG Error - version >= 1.11... no
configure: error: libgpg-error is needed.
Obviously I am doing something wrong, so its my fault, but this is
ABSOLUTELY HOPELESS if you want people to adopt gnupg. I work with
clients who don't know what an email client is, let alone what theirs is
called, on a wide variety of OSs. They cannot possibly do this all
this. Is it too much to ask that you produce an Ubuntu-friendly
repository that takes care of all the dependencies and compiling?
Rant over, please help.
More information about the Gnupg-users